当前位置:问答中心编程问题vite:yarn build 报错,错误是关于使用 ant-design-vue 的

vite:yarn build 报错,错误是关于使用 ant-design-vue 的

2
前端码农 管理员 提问于 6月 前

vite 打包报错。

错误是因为:

[vite]: Rollup failed to resolve import "G:/WorkMenu/front/node_modules/ant-design-vue/es/month-picker/style/index" from "src\views\attendance\schedule\index.vue".
This is most likely unintended because it can break your application at runtime.

错误的原因大概是:month-picker组件 ant-design-vue没有导出,然后我在页面中又使用了它。

import { MonthPicker } from 'ant-design-vue' 这个方式使用会打包失败… 给我整懵了。

将使用方式改成 import { DatePicker } from 'ant-design-vue'

然后组件改成 <DatePicker.MonthPicker> 这样子用后在打包才可以。

有什么办法解决这个问题吗。

1 人参与回答
1
空山新雨⁣ 管理员 发布于 6月 前

就用<DatePicker.MonthPicker>呗,文档上也是这样用的啊。

IT互联网行业相关广告投放 更专业 更精准

立即查看 联系我们