npm start报错: Node Sass version 6.0.1 is incompatible with ^4.0.0.at getRenderFuncFromSassImpl

vue项目yarn安装依赖之后,npm start报错:

Node Sass could not find a binding for your current environment: Windows 64-bit with Node.js 12.x

npm start报错: Node Sass version 6.0.1 is incompatible with ^4.0.0.at getRenderFuncFromSassImpl
翻译过来是Node Sass找不到当前环境的绑定,然后我试着用命令行 cnpm install node-sass 重新下载依赖,之前的错误消失,变成了:

Node Sass version 6.0.1 is incompatible with ^4.0.0.at getRenderFuncFromSassImpl

Node Sass version 6.0.1 is incompatible with ^4.0.0.at getRenderFuncFromSassImpl

这句话翻译过来是:Sass版本6.0.0与4.0.0不兼容,也就是目标项目中的node-sass版本过高
打开package.json文件查看node-sass版本为:

node-sass版本

查了资料后觉得还是版本不匹配的问题,所以就干脆一点:

  • cnpm uninstall node-sass 卸载依赖
  • npm install [email protected] 安装依赖

重新启动项目后,项目成功运行:

重新启动项目后,项目成功运行

版本还是:

重新启动项目后,项目成功运行

「点点赞赏,手留余香」

1

给作者打赏,鼓励TA抓紧创作!

微信微信 支付宝支付宝

还没有人赞赏,快来当第一个赞赏的人吧!

声明:本站所有资源及文章均来源于网络及用户分享或为本站原创,仅限用于学习和研究,任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。如若本站内容侵犯了原著者的合法权益,可联系我们进行处理。
码云笔记 » npm start报错: Node Sass version 6.0.1 is incompatible with ^4.0.0.at getRenderFuncFromSassImpl

发表评论

IT互联网行业相关广告投放 更专业 更精准

立即查看 联系我们